pijul_org / pijul

#142 Report error rather than panic when pushing to problematic repo

Opened by Nzen, on July 31, 2017
Closed
Nzen commented on July 31, 2017

Created repo biased mustard some time ago. Tried to push patches to repo now, pijul panicked.

I acknowledge the repo may be problematic because my pc copy of firefox reports "Secure Connection Failed / The connection to the server was reset while the page was loading.". My phone's copy of chrome reports "This page isn't working. / nest.pijul.com didn't send any data ERR_EMPTY_RESPONSE"

pijul 0.7.2 ;; thrussh v0.13.3 ;; rustc 1.19.0 (0ade33941 2017-07-17) ;; linux mint 17.1

RUST_BACKTRACE=1 pijul push Nzen@nest.pijul.com:Nzen/biased-mustard-twentyeight

Shall I push this patch? [ynkad] y
thread 'main' panicked at 'called `Result::unwrap()` on an `Err` value: Error(Disconnect)', /checkout/src/libcore/result.rs:860
stack backtrace:
   0: std::sys::imp::backtrace::tracing::imp::unwind_backtrace
             at /checkout/src/libstd/sys/unix/backtrace/tracing/gcc_s.rs:49
   1: std::sys_common::backtrace::_print
             at /checkout/src/libstd/sys_common/backtrace.rs:71
   2: std::panicking::default_hook::{{closure}}
             at /checkout/src/libstd/sys_common/backtrace.rs:60
             at /checkout/src/libstd/panicking.rs:355
   3: std::panicking::default_hook
             at /checkout/src/libstd/panicking.rs:371
   4: std::panicking::rust_panic_with_hook
             at /checkout/src/libstd/panicking.rs:549
   5: std::panicking::begin_panic
             at /checkout/src/libstd/panicking.rs:511
   6: std::panicking::begin_panic_fmt
             at /checkout/src/libstd/panicking.rs:495
   7: rust_begin_unwind
             at /checkout/src/libstd/panicking.rs:471
   8: core::panicking::panic_fmt
             at /checkout/src/libcore/panicking.rs:69
   9: core::result::unwrap_failed
  10: pijul::commands::remote::Session::push
  11: pijul::commands::push::run
  12: pijul::main
  13: __rust_maybe_catch_panic
             at /checkout/src/libpanic_unwind/lib.rs:98
  14: std::rt::lang_start
             at /checkout/src/libstd/panicking.rs:433
             at /checkout/src/libstd/panic.rs:361
             at /checkout/src/libstd/rt.rs:59
  15: __libc_start_main
  16: <unknown>

Also, consider updating the last line of Nest's getting started page. It currently says the push format is pijul push me@nest.pijul.com:repository . But, in reading discussions, I've seen the new format is pijul push me@nest.pijul.com:*user/*repository

Nzen commented on July 31, 2017

It seems as though the problematic repo correlates with the behavior distinctly from a nonexistent repo. Misspelling the url in my browser provides a proper "Not found" 404 page. Pijul push to the same misspelling quietly exits after confirming all the patches.

Nzen commented on July 31, 2017

While there are some other problematic repos {sandbox, test, and angst}, newly created nest repos do not exhibit the causative behavior. So, my motivation for this discussion is sated.

pmeunier commented on October 21, 2018

This has been solved a long time ago, thanks for reporting anyway.