pijul_org / pijul

#351 Cannot pull nor clone

Opened by lthms, on December 18, 2018
Closed
lthms commented on December 18, 2018

I am trying to get back to pijul dev recently, but I keep running in strange issues.

Currently, I cannot clone nor pull, either with cargo version or my local version. It says there are missing dependencies, which make libpijul::apply panics.

ndavis commented on December 18, 2018

I added the patch hashes to the error! message, and this is what I got:

ERROR 2018-12-19T01:46:34Z: libpijul::apply: Dependency 6v9QTu4f2kCK1FsbrN5ySD3Jt4aQBCz1JtQRJ6944pYquFuZBbczN6UN4511yxzyTKS5YeVa4GS7fHTfFwa7LQpZ not found for patch AaXEzugFnH486jcMC26fGRZ2TES2xSiwJA21ngj1Sd1eh7xvBqg9akC9zMvpyKkK95LoyFYZsYYxCmrsvzkKt2dw
thread 'main' panicked at 'called `Option::unwrap()` on a `None` value', libcore/option.rs:355:21

I recorded this change in my local repository, but when I tried to push I was only prompted to push three unrelated patches:

  • 9tNKV1UL5cYbw3gpDScSfoZSRthQ3a6KHHKMQTjA1CyCumqrVcXey6t37qJMHURpZQwZt1UsKoj3bhNPfevwdhTK - Init
  • 8Fviczf3R1U8ncVX2qJDjVP3iNg1hj4Zj5S33EFqpsK5njQyFsDWXbxLVdsSxi57xbfZtJm6yd1qkC3fV1a6RFUx - Diff algorithms (as a separated crate)
  • AA9uwuNF8MaFDNmwS84LykcaE4kvd3KbLgjQfjyQnzGnaTP71E8wywrVtsQdX9SyV1VUhnLgDNeyJ8HJz7voQ925 - chore: Add a minimal .ignore file for pijul status to be usable
krixano commented on December 20, 2018

This is the error I get when I try to clone pijul:

thread 'main' panicked at 'called Result::unwrap() on an Err value: Inner { kind: Hyper(Error { kind: Incomplete }), url: Some("https://nest.pijul.com/pijul_org/pijul/.pijul/patches/6dqHGNpTYbjXToLiAZnb3xP6KcLrkMr9ecLGP9sTAr8jc8JPxap9f1SWAayUoKSqSu6AhiCB92abrjZBxbvVbxoW.sig") }', libcore/result.rs:1009:5

pmeunier commented on December 21, 2018

@krixano: this is a different error, and has been fixed in the latest master. You should still be able to clone using SSH.

pmeunier commented on December 21, 2018

Btw, I fixed this error, it was related to libpijul (and therefore the Nest) allowing one to push patches without pushing dependencies, if one of the sides (pijul or the nest) crashed before all patches were applied: missing dependencies just caused a message instead of a hard error.

This is now fixed in libpijul, should be fixed in the Nest as soon as we release a new libpijul.

krixano commented on December 21, 2018

Just cloned pijul via ssh, did a cargo build, then did cargo install --force (but had to do it in pijul directory of repo). Then, I tried cloning pijul via https, and I get a similar error again.

krixano commented on December 21, 2018

So, I think I did it wrong before or something, idk - I did the whole process again, but instead of doing cargo install in the pijul subdir, I just did cargo build in repo root and moved the pijul exe to the .cargo/bin directory. Now cloning via https works.

lthms commented on January 9, 2019

I think this issue has been fixed now (thanks @pmeunier) but the current tree contains conflicts unfortunately.

sunjay commented on February 2, 2019

Ok. For future people, this is the command I had to run:

pijul clone sunjay@nest.pijul.com:pijul_org/pijul

You should substitute my username for your own.

I also had to add my public SSH key on my profile page: https://nest.pijul.com/sunjay

It did not work until I did that.

coconut commented on February 3, 2019

According to the README, pijul clone https://nest.pijul.com/pijul_org/pijul should work, but it fails with the following error:

thread 'main' panicked at 'called `Result::unwrap()` on an `Err` value: Error { kind: Hyper(Error { kind: Incomplete }), url: Some("https://nest.pijul.com/pijul_org/pijul/.pijul/patches/A1fotFtm1MmBgAuCXu6aWFYsRNfugfEXLwXB7gDQP3xTQDuF3xA8DnkPQR4eCTUwHZUgS1qBcsKvtPVJySaFzwxc.sig") }', src/libcore/result.rs:1009:5
note: Run with `RUST_BACKTRACE=1` for a backtrace.

I installed pijul just a few minutes ago using cargo install --force pijul, the version seems to be 0.11.1.

lthms commented on March 2, 2019

I suspect this is a bug in the Nest, as I can clone from a private server using pi-hoole (eg. pijul clone https://pijul.lthms.xyz:pijul/pi-hoole works for me)

Edit: Looks like this has been fixed, so I am closing.