I imagine you plan to get to this later, but would be nice to add a newline between patch entries in the "changes" list, and add some color a la darcs, for easier readability.
This shouldn’t be too hard to improve.
As far as I can tell, the changes command is actually using the print_patch_descr function (see line 29).
However, this function is also called when pushing/pulling/unrecording.
Good first bug! Try to do it, break things, ask as many questions as you want!
The output has been updated and is now nicer. Closing that for now.