The sound distributed version control system

#371 [BUG] pijul thinks that a freshly cloned repo has had all its files undeleted and other repo issues

Opened by nikitalita on February 27, 2021 Beta
nikitalita on February 27, 2021

regression on Windows at some point between version v1.0.0-alpha41 and v1.0.0-alpha44.

Tested this with the pijul repo using pijul v1.0.0-alpha44: https://pastebin.com/xZPXJmfb

It seems that this regression is in the repo format itself; I tried to go back to v1.0.0-alpha41 and reclone the repo, same thing.

Unfortunately, I can’t really regression test this since I no longer have a working copy of the pijul repo :(

nikitalita on February 27, 2021

Ok, this is apparently not just a windows issue. The sanakirja-1.0 repo is having similar issues on Linux:

https://pastebin.com/Nu7Gb2fj

However, I’m not getting the same issues with this repository on Windows.

nikitalita on February 27, 2021

Based on other’s regression testing, it looks like it started with change X243Z.

pmeunier on February 28, 2021

Thanks for your report! The semantics of file permissions has changed with X243Z, but this shouldn’t affect Windows, this is strange. Can you paste the output of cloning with environment variable RUST_LOG="libpijul=debug"? Thanks!

pmeunier on February 28, 2021

I would actually be interested in RUST_LOG="libpijul::record=debug,libpijul::working_copy=debug"

The_Decryptor on March 1, 2021

I didn’t get any debug output at all when cloning with RUST_LOG="libpijul::record=debug,libpijul::working_copy=debug", but I ran diff on the resulting repo with those flags and this is what I got.

https://dweb.link/ipfs/QmYcUFF8wvWZ5gcrG1f9fQAdkpSooUGrwzac1yM6TDEMTG?filename=pijul.log

pmeunier on March 1, 2021

So, for the Sanakirja repository, it is expected, I haven’t pushed the relevant patch yet.

@The_Decryptor: sorry for being unclear, you did the right thing (running diff with these flags).

Is this also on Windows? Which filesystem?

Also, since things have changed quite drastically, would you mind testing again with pijul 1.0.0-alpha.45 (released today)? I can’t reproduce this at all.

The_Decryptor on March 2, 2021

Yep, Windows 10 (20H2), filesystem is NTFS.

Tried again with alpha 45 from crates.io (Previous log was from a self built copy), same issue with a fresh clone.

https://dweb.link/ipfs/QmdVkYxXESgAU1vxCpmkko1iiKsWAYrhkK6imXJmZrTWSM?filename=pijul.45.log

pmeunier added tag Beta on April 29, 2021